Issue with withdrawal creation
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Dec 23, 2021 - 11:06 CST
Investigating
We are having some issue with withdrawal creating. Team has identified the issue and they are working on the fix. Sorry for inconvenience.
Posted Dec 23, 2021 - 10:59 CST