Bitso website and mobile apps are showing degradated performance
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 14:30 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2022 - 14:06 CDT
Investigating
We are experiencing degraded performance on our web and mobile applications. Our engineering team is already working on the issue. We are sorry for the inconveniences this might cause.
Posted Jun 09, 2022 - 14:01 CDT