Delays in completing transactions on the NEAR blockchain
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 03:31 UTC
Investigating
We have identified delays in completing transactions on the NEAR blockchain due to issues with a third party provider's infrastructure.

Our engineering team is following up with them to restore the service at the earliest.
Posted Mar 12, 2024 - 23:55 UTC
This incident affected: Cryptocurrencies 🌎 (NEAR (NEAR)).