SMS delivery delayed
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 23:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2022 - 23:18 UTC
Investigating
We are currently experiencing sms delays due to an ongoing issue at our sms partner's end. We are monitoring the situation closely and will update once issue is resolved. Sorry for the inconvenience.
Posted Aug 17, 2022 - 21:40 UTC
This incident affected: Phone Verification.