BTC/BCH/LTC - Withdrawals disabled
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jun 02, 2022 - 20:13 UTC
Investigating
Withdrawals for BTC/BCH/LTC has been disabled due to an ongoing issue. Our team is working on the fix, it will be enabled as soon as fix is implemented.
Posted Jun 02, 2022 - 19:04 UTC
This incident affected: Cryptocurrencies 🌎 (Bitcoin Cash (BCH), Bitcoin (BTC), Litecoin (LTC)).