A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2026 - 13:36 UTC
Update
We are continuing to investigate this issue and will keep you posted. We apologize for any inconvenience this may cause.
Posted Apr 27, 2026 - 10:37 UTC
Investigating
We are currently experiencing issues on MXN withdrawals. Due to this, MXN withdrawals are temporarily disabled. Our engineering team is working to identify the root cause and restore normal processing as quickly as possible.
We apologize for any inconvenience this may cause.
Actualmente estamos experimentando problemas con los retiros en MXN. Debido a esto, los retiros en MXN están desactivados temporalmente. Nuestro equipo de ingeniería está trabajando para identificar la causa raíz y restaurar el procesamiento normal lo más rápido posible.
Lamentamos cualquier inconveniente que esto pueda causar.
Posted Apr 26, 2026 - 18:39 UTC
This incident affected: Mexican pesos (MXN) 🇲🇽 (Bank Transfer (SPEI)).