Landing pages https://bitso.com and https://bitso.com/alpha having degrade performance
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Sep 11, 2022 - 05:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 11, 2022 - 05:05 UTC
Investigating
We are having degraded performance on https://bitso.com and https://bitso.com/alpha landing pages. We are working on to fix this as soon as possible. Users can use the platform by directly login through https://bitso.com/login or use bitso mobile app until this is resolved.
Posted Sep 11, 2022 - 04:15 UTC
This incident affected: Bitso Website 🖥 and Bitso Alpha 📈.