https://bitso.com/login URL temporarily unavailable
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 10:34 CDT
Investigating
The https://bitso.com/login, bitso.com/alpha/login and bitso.com/register URLs are temporarily unavailable. Our team is already working on this case.
Please continue operating through our mobile app. We apologize for the inconvenience.


Las URLs https://bitso.com/login, bitso.com/alpha/login y bitso.com/register no se encuentran disponibles temporalmente. Nuestro equipo se encuentra trabajando en este caso.
Por favor continue operando a través de nuestra aplicación móvil. Disculpe los inconvenientes.


https://bitso.com/login, bitso.com/alpha/login e bitso.com/register estão temporariamente indisponíveis. Nosso time já está trabalhando nisso. Por favor continuem operando através das aplicações mobile. Desculpem os inconvenientes.
Posted Jul 28, 2022 - 09:51 CDT
This incident affected: Bitso Website 🖥.