Pricing details for assets is not displayed

Incident Report for Bitso

Resolved

This incident has been resolved
Posted Oct 24, 2023 - 08:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2023 - 00:56 UTC

Identified

We have an ongoing issue that prevents users from viewing price details on the web and app. Our engineering team is working on to fix this as soon as possible
Posted Oct 23, 2023 - 23:20 UTC
This incident affected: Bitso Website 🖥, Bitso Mobile 📱, and Bitso Alpha 📈.