Issue with KYC validation process
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 18:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2024 - 17:15 UTC
Investigating
We are experiencing issues with use our kyc validation process due to which users may see a message to complete their data. Our engineers are working to fix this issue. Sorry for the inconvenience!
Posted Mar 05, 2024 - 16:20 UTC
This incident affected: Identity Proofing.