Problem with mobile wallet (iOS & Android)
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jul 04, 2022 - 22:15 CDT
Investigating
We are having issue with mobile (iOS & Android) wallet. Our engineering team is reviewing and working on to fix this as soon as possible. In the mean time users can view their wallet using web (https://bitso.com/).
Posted Jul 04, 2022 - 21:42 CDT
This incident affected: Bitso Mobile 📱.