Problem with btc/ltc/bch withdrawals
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 18:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2021 - 18:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 20, 2021 - 18:20 UTC
Investigating
We are facing issue with btc/ltc/bch withdrawals. Our engineering team has identified the problem and they are working on to resolve the it as soon as possible. We will let you know once it is fixed. Sorry for the inconvenience.

Descubrimos algunos inconvenientes con los retiros de BTC/LTC/BCH. Nuestro equipo de ingeniería ya identificó el problema y está trabajando para resolverlo lo antes posible. Te avisaremos cuando esté solucionado y te pedimos disculpas por las molestias.
Posted Sep 20, 2021 - 18:20 UTC
This incident affected: Cryptocurrencies 🌎 (Bitcoin Cash (BCH), Bitcoin (BTC), Litecoin (LTC)).