Deposits and withdrawals delayed
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Jun 07, 2022 - 12:15 CDT
Update
Withdrawals were enabled again. Our engineering team remains gathered to fix the issue. For any help reach-out to our support at https://support.bitso.com/
Posted Jun 07, 2022 - 10:14 CDT
Update
Withdrawals for all currencies had to be disabled. Our engineering team is still working to fix this issue.
Sorry for the inconvenience.
Posted Jun 07, 2022 - 09:14 CDT
Update
We are continuing investigating the issue. Sorry for the inconvenience. For any help reach-out to our support at https://support.bitso.com/
Posted Jun 07, 2022 - 08:02 CDT
Investigating
We are experiencing delay with deposits and withdrawals. Our engineering team is working on to fix this as soon as possible. For any help reach-out to our support at https://support.bitso.com/
Posted Jun 07, 2022 - 00:37 CDT