BTC, LTC, BCH, XRP withdrawals outage

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 19:15 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 03, 2025 - 19:15 UTC

Identified

BTC, LTC, BCH withdrawals have been enabled and transactions are flowing fine. Our Team is still working on this case. At the moment, issues persist for XRP. Due to this, XRP withdrawal is temporarily disabled. We apologize for the inconvenience.
Posted Mar 03, 2025 - 18:36 UTC

Investigating

During our latest maintenance we experienced some issues, and due to these, withdrawals for Bitcoin (BTC), Bitcoin Cash (BCH), Litecoin (LTC) and XRP are temporarily disabled.
Our engineers are already working on this case. We apologize for the inconvenience.
Posted Mar 03, 2025 - 18:07 UTC
This incident affected: Cryptocurrencies 🌎 (Bitcoin Cash (BCH), Bitcoin (BTC), Litecoin (LTC), XRP (XRP)).