Bitso web login issue
Incident Report for Bitso
Resolved
This incident has been resolved.
Posted Aug 09, 2024 - 15:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 09, 2024 - 15:53 UTC
Investigating
We are facing issue with our web login. Our engineering team is already working to resolve this situation at the earliest.

We apologize for the inconvenience.
Posted Aug 09, 2024 - 15:48 UTC
This incident affected: Bitso Website 🖥 and Bitso Alpha 📈.