A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2025 - 03:43 UTC
Update
We are continuing to investigate this issue.
Posted Feb 05, 2025 - 03:43 UTC
Investigating
Currently we are facing issues with finalizing transactions on Ethereum blockchain. Transactions may stuck in confirming status for a delayed time. Sorry for the inconvenience!