Degradation on CURP validations

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted Jan 31, 2026 - 06:19 UTC

Investigating

Due to an issue with a third-party provider's infrastructure, we observe degradation to validate CURP for Mexican clients . Our engineering team is following up on this to restore the service at the earliest.

We apologize for the inconvenience.

If you need further assistance, please contact us through our Help Center at https://support.bitso.com/
Posted Jan 31, 2026 - 04:55 UTC